Access 2010
Creating Reports
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Introduction

If you need to share information from your database with someone, but don't
want them actually working with your database, you should consider creating a
Report. Reports allow you to organize and present your data in a reader-
friendly, visually appealing format. Access 2010 makes it easy to create and
customize a report using data from any query or table in your database.

In this lesson, you will learn how to create, modify, and print reports.

We will be showing you how to create reports from tables and queries in
sample bakery database. If you would like to follow along, download our

example and use it to follow the procedures demonstrated in this lesson.
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Creating Reports
Reports give you the ability to present components of your
database in an easy-to-read, printable format. Access 2010 Video: Creating Reports in

lets you create reports from both tables and queries. Access 2010

Watch the video (2:26). Need help?

To Create a Report:

1. Open the table or query you would like to use in your report. We want to print out a list of last month's orders,
so we'll open up our Orders Query.
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The query we'll use in our report

2. Select the Create tab on the Ribbon and locate the Reports group. Click the Report command.

The Report command

3. Access will create a new report based on your object.

4. It's likely that some of your data will be located on the other side of the page break. To fix this, resize your

fields. Simply select a field, then click and drag its edge until the field is the desired size. Repeat with
additional fields until all of your fields fit.
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Resizing fields in the report

5. To save your report, click the Save command on the Quick Access Toolbar. When prompted, type a
name for your report and then click OK.

Saving and naming the report

Just like tables and queries, reports can be sorted and filtered. Simply right-click the field you wish to sort or
filter. Then, select the desired sorting or filtering option.
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Filtering a report

Deleting Fields

You might find that your report contains some fields you don't really need to view. For instance, our report
contains the Zip Code field, which isn't really necessary in a list of orders. Fortunately, you can delete fields in
reports without affecting the table or query you got your data from.

To Delete a Field in a Report:

1. Click any cell in the field you would like to delete.
2. Press the delete key.

When you delete a field, be sure to delete its header as well. Simply select the header and press the delete key.
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Deleting a field header after deleting
the related field
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Printing and Saving Reports in Print Preview
While you can print reports using commands in the
Backstage view, you can also use Print Preview. Print Video: Printing Reports in

Preview shows you how your report will appear on the printed Access 2010
page. It also allows you to modify the way your report is

displayed, print it, and even save it as a different file type.

Watch the video (2:27). Need help?

Click the buttons in the interactive below to learn about Print Preview.
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To Print a Report:

1. On the Home tab of the Ribbon, click the View command and select Print Preview from the drop-down
list. Your report will be shown as it will appear on the printed page.
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Switching to Print Preview
view

2. If necessary, modify the page size, margin width, and page orientation using the related commands on
the Ribbon.

Page setup commands in Print Preview

3. Click the Print command.
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The Print command

4. The Print dialog box will appear. Set any desired print options, then click OK.

Saving Reports

You can save reports in other formats so that they'll be viewable outside of Access. This is called exporting a
file, and it allows you to view and even modify reports in other formats and programs.

Access offers options to save your report as an Excel file, a Text file, a PDF, an XPS file, an email
attachment, a Rich Text file, or an HTML document. Experiment with the different export options to find the
one that best suits your needs.

To Export a Report:
1. Onthe Home tab of the Ribbon, click the View command and select Print Preview from the drop-down
list.
2. Locate the Data group on the Ribbon.

3. Select one of the file type options on the Ribbon, or click More to see options to save your report as a Word
or HTML file.

Report export options

4. Save your file.
o If you're saving the report as a PDF or XPS file:
1. Select the location where you wish to save the report.

2. Place your cursor in the file name text box and type a name for your report if you wish to name
it something other than the report title.
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3. Inthe Save as Type drop-down menu, select either PDF or XPS.

4. Select the file quality by clicking either Standard for reports you plan on printing or
Optimized for reports you plan to share primarily online.

5. Once you are satisfied with your settings, click Publish to save your report.

Saving the report as a PDF or XPS file

o If you're saving the report as any other type of file:
1. Click Browse to specify your file location and name, then click Save.

2. Inthe Export dialog box, click the checkboxes to select desired saving options where
applicable,

3. Click OK to export your report.
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Saving the report as an Excel, Word, text, or HTML file

5. A dialog box will appear to notify you that your file has been successfully saved. Click Close to return to your
report.
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Challenge!

If you haven't already, download our sample database and open it.

Open the Customers Who Live Nearby query and use it to create a report.
Resize the fields and rows so that all of the information is visible.

Ao bdh =

Move any fields located on the right side of a page break onto the same page
as the other fields.

5. Export the report as a PDF file.
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Access 2010
Advanced Report Options
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Introduction

Access 2010 offers several advanced options for creating and modifying
reports. The Report Wizard is a tool that guides you through the process of
creating complex reports. Once you've created a report, whether through the

Report Wizard or the Report command, you can then format it to make it look
exactly how you want.

In this lesson, you'll learn how to use the Report Wizard to create complex
reports. You'll also learn how to use Access's formatting options to format
text, change report colors and fonts, and add a logo.

We will be showing you how to create and modify reports with examples from our sample database. If you would
like to follow along, download our example and use it to follow the procedures demonstrated in this lesson.
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The Report Wizard

While using the Report command is a quick way to create

reports from the current object, it's not as helpful if you want to Video: Using the Report
create a report with data from multiple objects. The Report Wizard in Access 2010
Wizard makes it easy to create reports using fields from
multiple tables or queries. It even lets you choose how your
data will be organized.

Watch the video (3:09). Need help?

To Create a Report using the Report Wizard:
1. Select the Create tab and locate the Reports group. Click the Report Wizard command.
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The Report Wizard command

2. The Report Wizard dialog box will appear.

The Report Wizard dialog box

Step 1: Select the Fields to Include in your Report

1. Click the drop-down arrow to select the table or query that contains the desired field or fields.
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Selecting a table that contains fields to include in the report

2. Select a field from the list on the left and click the right arrow to add it to the report.

Adding fields to a report

3. You can add fields from more than one table or query by repeating the above steps. Once you've added the
desired fields, click Next.
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The added fields

Step 2: Organize the Report

The Report Wizard will provide you with options that let you choose how to view and organize your data. These
options group like data within your fields and organize those fields into multiple levels, like in an outline or
bulleted list.

If you are building a report from only one table or query, you can skip to #3 in this section.

1. Access will offer a list of several organization options. Select an option from the list to preview it.
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Grouping options

2. Click Next when you are satisfied with the basic organization of your data.
3. If you're not satisfied with the way your data is organized, you can now modify the grouping levels.
o Select a field from the list and click the right arrow to add it as a new level.

Adding a new grouped level

o If necessary, modify the order of your grouped fields by selecting a field and clicking the up or down
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Priority arrow to move it up or down a level.

Moving the Sales Unit field down a grouping level

4. Once you are satisfied with the organization of your report, click Next.

Step 3: Sort your Report Data

1. Click the top drop-down arrow, and select the name of the first field you wish to sort.
2. Click the button on the right to change the sort to ascending or descending.
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Sorting the report

3. Add any additional sorts. You may sort up to four fields. The sort will be applied from top to bottom,
meaning that the sort at the top of the list will be the main sort.

4. When you are satisfied with the way your data is sorted, click Next.

Depending on the grouping you have chosen for your data, your sorting options may be limited.

Step 4: Select a Layout and Title

1. Click the various layout options to see how they look, then select one to use in your report.
2. Select either a portrait (tall) or landscape (wide) orientation for your report.

Setting the report layout
3. Once you are satisfied with your report layout, click Next.

4. Place your cursor in the text box and type the title you would like for your report.
5. Select whether you want to preview the report or modify its design, then click Finish.
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Finishing the report

6. Your report will be created and saved.

Just as with other reports, you may have to adjust your field and row size and location to make sure that all your
data fits the way you want it to.
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Formatting Reports
One of the strengths of reports is that you can modify their
appearance to make them look how you want. You can add Video: Formatting Reports in

headers and footers to your report, apply hew colors to the Access 2010
layout, and even add a logo. All of these things can help you
create visually appealing reports.

Watch the video (3:54). Need help?
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Modifying Report Text

The bulk of the information in your report comes straight from the query or table you built it from, which means you
can't edit it within the report. However, you can change, add, or delete label text, headers, and footers to make
your report clearer and easier to read. For example, in our report, we decided that we didn't need the field
headings to understand our data, so we simply deleted them.

When working with text and text boxes in reports, you can use many of the text and shape formatting tools you
use in other Office programs to modify color, font, and more. If you're not sure how to perform basic text and
shape formatting, please visit the Formatting Text and Working With Shapes lessons in our Word 2010 course.

The report, with simple text formatting applied

Modifying the Page Header and Footer

To view and modify the header and footer that appear on every page of your report, select the View command
on the Ribbon and switch to Design View. The header and footer are located in the white space beneath the
Page Header and Page Footer bars.
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The page header and footer in Design View

Depending on your report's design, sometimes you may find that there is no white space in the page header and
footer, as in the image above. If this is the case, you must resize the header and footer before you can add
anything to them. Simply click and drag the bottom border of the header or footer to make it larger.

Resizing the page header

To Add Text to a Header or Footer:

1. On the Ribbon, select the Design tab in the Report Design Tools group and locate the Controls group.
2. Select the Label command.
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The Label command

3. Place your cursor in the white space in your header or footer, and click and drag to create your label.
Release the mouse when it is the desired size.

Clicking and dragging to create a label

4. Place your cursor in the text box, click once, and type the desired text.
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Adding text to the label

To Add the Date and Time to a Header or Footer:

1. On the Ribbon, select the Design tab in the Report Design Tools group and locate the Header/Footer
group.
2. Select the Date and Time command.

The Date and Time command

3. The Date and Time dialog box will appear. Select the desired formatting options. A preview of the text that
will be included in your report will appear. When you are satisfied with the appearance of the date and time,
click OK.
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Selecting the date and time format in the
Date and Time dialog box

By default, the date and time appear in the header. If you would like to move them to the footer instead, simply
click the date and time boxes and drag them to the desired location.

To Add Page Numbers to a Header or Footer:

1. On the Ribbon, select the Design tab in the Report Design Tools group and locate the Header/Footer
group.
2. Select the Page Numbers command.

The Page Numbers command

3. The Page Numbers dialog box will appear. Select the format of the page numbers.
o Select Page N to display the number of only the current page.

o Select Page N of M to display the number of the current page and the number of total pages.
4. Select whether to put your page numbers in the header or footer.
5. Click the drop-down arrow to select the alignment of the page numbers.
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Selecting page number settings in the
Page Numbers dialog box

6. When you are satisfied with the settings, click OK.
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Enhancing Report Appearance

To Add a Logo:

1. On the Home tab of the Ribbon, click the View command and select Layout View from the drop-down list.

Switching to Layout View

2. Select the Design tab and locate the Header/Footer group, then select the Logo command.
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The Logo command

3. The Insert Picture dialog box will appear. Locate and select the desired image file and click OK to add it to
your report.

Inserting a logo

4. A shrunken version of your image will appear in the header. Click and drag the image border to resize it.
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Resizing the logo

5. If necessary, move your logo to the desired location by clicking and dragging it.

The resized, repositioned logo

Themes and Fonts

A theme is a set of colors and fonts that applies to the entire database to give it a consistent, professional
look. By default, databases use the Office theme. When you change the theme, all of the theme fonts and colors

in your database change to match the new theme. Designing and modifying reports using theme elements can
help you keep the appearance of your reports consistent.

To Change the Theme:

©1998-2013 Goodwill Community Foundation, Inc. All rights reserved.



1. Select the Design tab and locate the Themes group.
2. Click the Themes command.

The Themes command

3. A drop-down menu will appear. Hover the mouse over a theme to see a live preview of it.

Hovering to preview a new theme
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4. Select the desired theme. The theme will be applied to your entire database.

The report, now with a new theme

To Change the Theme Fonts:

1. Select the Design tab and locate the Themes group.
2. Click the Fonts command.

The Fonts command
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3. A drop-down menu will appear. Select a set of Theme Fonts.

Selecting a new set of theme fonts

4. The fonts will be applied to your entire database.
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The report, now with new fonts
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Challenge!

If you haven't already, download our sample database and open it.
Open the December Orders report.

Add the Date and Time to the Header.

Add Page Numbers to the Footer.

Select the report title and edit it to say December Orders.
Choose a new theme and new theme fonts.

No akowbdh--

Add a logo. You can use an image from your computer or download our logo.
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